BADSIG error with aptitude/apt

Have been running Debian Squeeze 6.x on my desktop at work for quite a while now, and lately had a problem where I was repeatedly getting BADSIG errors with a couple of repos.  Mostly debian-multimedia, and also with security.debian.org as well.

The solution was to comment out the problematic repos, and then do:

aptitude update

after this enable the repos again and run:

aptitude update

after this all was OK again.  I had seem some posts where it suggested reinstalling the keyrings, but this never solved the problem for me.